Python version 3.5 does not support variable...

Stella981 等级 133 0 0

背景

目前处于FastAPI学习初期,使用环境是:

  • Win7 64 bits SP1
  • PyCharm 2016.3
  • Python 3.8.4
  • FastAPI 0.60.1

问题截图

Python version 3.5 does not support variable...

错误提示

如图所示,错误是“Python version 3.5 does not support variable annotations"。

...

目前有关此错误的解答国内网站上几乎没有。国外仅发现——没有***+GOOGLE,stackoverflow上个别提到,不符合我的情况。

我的情况是,前不久刚安装了系统WINDOWS 7 SP1 64bits+Python 3.8.4+PyCharm 2016.3。系统中根本没有Python 3.5相关内容。

但是,上面这种介绍FastAPI的代码,在国外网站上经常见到,但都没有提到类似于我的错误。

我的PyCharm设置1如下图:

Python version 3.5 does not support variable...

在”Default settings“下,也作了上面设置。
但是,都无济于事!

目前,此案件正在调查中......

收藏
评论区

相关推荐

Python Sanic 高并发服务开发指南
技术基础 AsyncIO Python 3.4 开始引入 AsyncIO(https://docs.python.org/3/library/asyncio.html) 模块,使得 Python 也支持异步 IO。3.5 版本里添加了 async/await 关键字,使得异步 IO 代码编写更加方便。3.6 和 3.7 版本继续进行了完善
数据分析 常见异常及解决办法(一)
1.Jupyter读取数据警告ParserWarning: Falling back to the 'python' engine because the 'c' engine does not support regex separators在使用Jupyter Notebook读取数据进行分析时,如下:python<ipythoninput
Java编译器级别与已安装的Java项目方面的版本不匹配。
问题:Description Resource Path Location Type Java compiler level does not match the version of the installed Java project facet. hotnet\_manage Unknown Faceted Project Problem (Jav
D02——C语言基础学PYTHON
C语言基础学习PYTHON——基础学习D02 **20180801内容纲要:**   **1** 字符串的系列操作   **2** 集合   **3**  文件的读写   **4** 字符编码转换   **5** 小结   **6** 练习:三级菜单(有彩蛋) **1 字符串的系列操作** 特性:不可修改。('str' object doe
ubuntu 和windows 分别在anaconda上安装tensorflow
windows下 的anaconda安装tensorflow: 在Anaconda Prompt中:conda install tensorflow python=3.5一直下载失败.总结一下原因可能国外的源,网速太慢且不稳定 借鉴http://www.cnblogs.com/nosqlcoco/p/6923861.html 把镜像改为清华大学开源软件
EasyPlayer.js H5播放器帮助我这种不会前端的普通用户也能轻松实现直播接入
说到EasyPlayer.js,先得说一下EasyPlayer到底是啥, > An elegant, simple, fast android RTSP/RTMP/HLS/HTTP Player.EasyPlayer support RTSP(RTP over TCP/UDP)version & RTMP(FLV)version & Pro version
Flask中无法在其他函数中查询Sqlachemy的解决办法
报错信息部分截取: ========= File "D:\python 3.5\lib\site-packages\flask_sqlalchemy\__init__.py", line 912, in get_app 'No application found. Either work inside a view function
Mac查看Python安装路径和版本
\[TOC\] #查看当前所有Python版本路径 appledeMBP:~ apple$ which python2.7 /usr/local/bin/python2.7 appledeMBP:~ apple$ which python3.5 /Library/Frameworks/Python.framework
NLP 基于kashgari和BERT实现中文命名实体识别(NER)
准备工作,先准备 python 环境,下载 BERT 语言模型 * Python 3.6 环境 需要安装`kashgari` Backend pypi version desc TensorFlow 2.x pip install ‘kashgari>=2.0.0’ coming soon TensorFlow 1.14+ pip ins
Python version 3.5 does not support variable...
背景 == 目前处于FastAPI学习初期,使用环境是: * Win7 64 bits SP1 * PyCharm 2016.3 * Python 3.8.4 * FastAPI 0.60.1 问题截图 ==== ![Python version 3.5 does not support variable...](https://s4
Python技巧之使用多个集合进行关键字传参
Python 3.5+ 允许在函数单次调用中使用多个集合进行关键字传参。语法为在变量前使用双星号“\*\*”。 # Python 3.5+ allows passing multiple sets # of keyword arguments ("kwargs") to a # function within a single ca
Python技巧之循环体中的条件分支
Python的‘for’和‘while’循环支持‘else’分句,分句仅在循环体没有触发‘break’语句并终止时执行。 # Python's `for` and `while` loops # support an `else` clause that executes # only if the loops terminates
SpringBoot项目集成cas单点登录
添加依赖 ---- 添加cas client依赖 <dependency> <groupId>net.unicon.cas</groupId> <artifactId>cas-client-autoconfig-support</artifactId>
SpringBoot项目集成cas单点登录
添加依赖 ---- 添加cas client依赖 <dependency> <groupId>net.unicon.cas</groupId> <artifactId>cas-client-autoconfig-support</artifactId>
swagger生成错误问题 汇总解决
### Unable to render this definition The provided definition does not specify a valid version field. Please indicate a valid Swagger or OpenAPI version field. Supported version f