MPLS VPN随堂笔记1

Stella981
• 阅读 710

MPLS VPN 基础

1、MPLS vpn架构的特点

1.1.允许不同CE传递相同私网路由

1.2.SP内部(所有P路由器)不需要学习CE路由

1.3.无安全保障但有带宽保障(跟SP租用服务)

2、MPLS vpn 架构的主要组件

CE 客户边缘路由器

C 客户内部路由器

PE 运营商边缘路由器

P 运营商内部路由器

RD 路由区分符(本地有效)

区分本地接收不同CE传递的路由

如1:1 (SP的 AS号:序号)

RT 路由目标(MPBGP拓展团体属性传递)

区分接收MPBGP传递来的路由是否接收

为MPBGP发送路由更新添加区分符

如2:2 (SP的 AS号:序号+标识)

发送方RT export值 与接收方import值 对应

MPBGP中传递路由:96位 = RD+私网路由

(1:1:192.168.1.0/24)

3、RD

4、RT

5、MP-BGP

总结MPBGP路由转发模式

     Mpls基础实验

1.配置SP内部网络(IGP ospf)

2.配置SP内部MPLS域(LDP)

R3(config)#interface s0/1

R3(config-if)#mpls ip

接口下启用LDP协议

R3(config)#mpls ldp router-id loopback 0 force

强制指定loopback0 为RID

R1#show mpls ldp neighbor

检查LDP邻居是否建立

R1#show mpls ldp discovery

如未建立 检查错误

3.配置MP-BGP

(起邻居)

router bgp 100

bgp router-id 3.3.3.3

no bgp default ipv4-unicast

(关闭默认单播ipv4BGP邻居建立)

bgp log-neighbor-changes

neighbor 1.1.1.1 remote-as 100

neighbor 1.1.1.1 update-source Loopback0

(全局指定邻居以及建立邻居地址)

address-family vpnv4

进入VPNV4地址族

neighbor 1.1.1.1 activate

激活邻居

neighbor 1.1.1.1 send-community extended

(默认激活后直接开启)

exit-address-family

R1#show ip bgp vpnv4 all summary

检查MPBGP邻居关系

MPLS VPN随堂笔记1

创建VRF(虚拟路由器)

ip vrf a(本地有效)

进入vrf配置界面

rd 1:1

配置RD值(本地有效)

route-target export 10:10

route-target import 20:20

设置RT出入方向值

R1#show ip vrf a

查看本地VRF

将接口划入VRF中

interface Serial0/1

ip vrf forwarding a

ip address 192.168.1.1 255.255.255.0

(注意要重写一遍地址)

R1#show ip route vrf a

查看虚拟路由表(对应vrf)

R1#ping vrf a 192.168.1.2

测试vrf下的直连

R1(config)#ip route vrf a 11.11.11.11 255.255.255.255 192.168.1.2

vrf下静态路由

router bgp 100

address-family ipv4 vrf a

redistribute static

在vrf地址族下 重分布静态路由

show ip bgp vpnv4 all neighbors 3.3.3.3 advertised-routes

查看是否给3.3.3.3(邻居)发送该路由

R1#show ip cef vrf a detail

查看vrf a相关联的FIB表

22.22.22.22/32, version 9, epoch 0, cached adjacency to Serial0/0

0 packets, 0 bytes

tag information set

local tag: VPN-route-head

fast tag rewrite with Se0/0, point2point, tags imposed: {16 104}

via 3.3.3.3, 0 dependencies, recursive

next hop 12.1.1.2, Serial0/0 via 3.3.3.3/32

下一跳出接口

valid cached adjacency

tag rewrite with Se0/0, point2point, tags imposed: {16(LDP分配的标签 104MPBGP分配的标签}

show ip bgp vpnv4 all labels

查阅MPBGP分配的标签

R1#show ip cef vrf a detail

查阅相关VRF a的FIB表

    ce-pe rip

router rip

version 2

no auto-summary

!

address-family ipv4 vrf a

在相对应的vrf地址族下重分布

redistribute bgp 100 metric 1

将路由重分布进rip时注意加metric值,如不加重分布不进rip

network 192.168.1.0

no auto-summary

exit-address-family

router bgp 100

address-family ipv4 vrf a

在相对应的vrf地址族下重分布

redistribute rip

检查邻居PE是否通过MPBGP学习到相对应的路由

show ip bgp vpnv4 all

(检查下一跳是否正确)

show ip route vrf b

检查vrf b路由表中是否存在

PE-CE EIGRP

router eigrp 100

no auto-summary

!

address-family ipv4 vrf a

进入相对vrf地址族下

redistribute bgp 100 metric 1000 100 255 1 1500

将其他协议重分布进来需要加metric值

(直连 静态 eigrp其他自制系统)

network 192.168.1.0

autonomous-system 100

强制指定本地AS,否则邻居无法建立

exit-address-family

R1#show ip eigrp vrf a neighbors

检查EIGRP 相对vrf下邻居

PE-CE OSPF

router ospf 2 vrf a

创立ospf进程号时直接关联vrf

router-id 11.1.1.1

log-adjacency-changes

redistribute bgp 100 subnets

引入BGP路由时注意加 subnets

network 192.168.1.0 0.0.0.255 area 0

router bgp 100

address-family ipv4 vrf a

redistribute ospf 2 vrf a

如果直接重分发 默认只会把OSPF域内 区域间(OIA) 区域内部(O)重分发

如果需要将ospf域内 OE2路由引入 需要加match项

redistribute ospf 2 vrf a match match internal external nssa-external

no synchronization

exit-address-family

PE-CE BGP

CE端

router bgp 65000

no synchronization

bgp router-id 5.5.5.5

bgp log-neighbor-changes

network 22.22.22.22 mask 255.255.255.255

起源路由

neighbor 192.168.2.1 remote-as 100

建立EBGP邻居

neighbor 192.168.2.1 allowas-in 10(发生次数)

允许接收带有自己AS号的路由更新

PE端

router bgp 100

address-family ipv4 vrf b

进入对应VRF地址族下

neighbor 192.168.2.2 remote-as 65000

建立EBGP邻居

neighbor 192.168.2.2 activate

no synchronization

一般用直连建立EBGP邻居

点赞
收藏
评论区
推荐文章
blmius blmius
2年前
MySQL:[Err] 1292 - Incorrect datetime value: ‘0000-00-00 00:00:00‘ for column ‘CREATE_TIME‘ at row 1
文章目录问题用navicat导入数据时,报错:原因这是因为当前的MySQL不支持datetime为0的情况。解决修改sql\mode:sql\mode:SQLMode定义了MySQL应支持的SQL语法、数据校验等,这样可以更容易地在不同的环境中使用MySQL。全局s
Jacquelyn38 Jacquelyn38
2年前
2020年前端实用代码段,为你的工作保驾护航
有空的时候,自己总结了几个代码段,在开发中也经常使用,谢谢。1、使用解构获取json数据let jsonData  id: 1,status: "OK",data: 'a', 'b';let  id, status, data: number   jsonData;console.log(id, status, number )
皕杰报表之UUID
​在我们用皕杰报表工具设计填报报表时,如何在新增行里自动增加id呢?能新增整数排序id吗?目前可以在新增行里自动增加id,但只能用uuid函数增加UUID编码,不能新增整数排序id。uuid函数说明:获取一个UUID,可以在填报表中用来创建数据ID语法:uuid()或uuid(sep)参数说明:sep布尔值,生成的uuid中是否包含分隔符'',缺省为
good123 good123
2年前
RIP路由协议
动态路由定义:各个路由器之间运行某种协议(算法),通过收发数据包的形式获取未知路径(路由器交换信息)。动态路由的特点减少了管理任务占用了网络带宽动态路由协议概述路由器协议:路由器之间用来交换信息的语言。度量值:跳数、带宽、负载、时延、可靠性、成本路由器通过度量值来确定最优路由路径收敛使所有路由表都达到一致状态的过程静态路由和动态路由的关系网络中静态路由和动态
Wesley13 Wesley13
2年前
mysql设置时区
mysql设置时区mysql\_query("SETtime\_zone'8:00'")ordie('时区设置失败,请联系管理员!');中国在东8区所以加8方法二:selectcount(user\_id)asdevice,CONVERT\_TZ(FROM\_UNIXTIME(reg\_time),'08:00','0
Wesley13 Wesley13
2年前
00:Java简单了解
浅谈Java之概述Java是SUN(StanfordUniversityNetwork),斯坦福大学网络公司)1995年推出的一门高级编程语言。Java是一种面向Internet的编程语言。随着Java技术在web方面的不断成熟,已经成为Web应用程序的首选开发语言。Java是简单易学,完全面向对象,安全可靠,与平台无关的编程语言。
Stella981 Stella981
2年前
Django中Admin中的一些参数配置
设置在列表中显示的字段,id为django模型默认的主键list_display('id','name','sex','profession','email','qq','phone','status','create_time')设置在列表可编辑字段list_editable
Stella981 Stella981
2年前
Docker 部署SpringBoot项目不香吗?
  公众号改版后文章乱序推荐,希望你可以点击上方“Java进阶架构师”,点击右上角,将我们设为★“星标”!这样才不会错过每日进阶架构文章呀。  !(http://dingyue.ws.126.net/2020/0920/b00fbfc7j00qgy5xy002kd200qo00hsg00it00cj.jpg)  2
Wesley13 Wesley13
2年前
MySQL部分从库上面因为大量的临时表tmp_table造成慢查询
背景描述Time:20190124T00:08:14.70572408:00User@Host:@Id:Schema:sentrymetaLast_errno:0Killed:0Query_time:0.315758Lock_
Python进阶者 Python进阶者
3个月前
Excel中这日期老是出来00:00:00,怎么用Pandas把这个去除
大家好,我是皮皮。一、前言前几天在Python白银交流群【上海新年人】问了一个Pandas数据筛选的问题。问题如下:这日期老是出来00:00:00,怎么把这个去除。二、实现过程后来【论草莓如何成为冻干莓】给了一个思路和代码如下:pd.toexcel之前把这